'Your First Rails Project' Problems With Uninstalling Ruby


#1

Hi folks,

I’m having a heck of a time here and have decided to uninstall Ruby and try again in a few days if the issues with the new version are resolved.

I’ve tried the following:

~$ sudo apt remove ruby 2.6.3p62
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package 2.6.3p62
E: Couldn’t find any package by glob ‘2.6.3p62’
E: Couldn’t find any package by regex ‘2.6.3p62’

As you can see, I don’t think I’m having much success. How do I find the correct argument for uninstalling Ruby?

Many thanks.


#2

If you used rbenv to install ruby you can use rbenv to remove it. That said I don’t think ruby is the issue. It’s probably rails that is the problem as that’s just had a major release.

You can use gem uninstall rails

I think…

If not just google for the right syntax to remove a ruby gem.


#3

Your trouble might be due to rails recently updating to v6.0.0 - It seems to be causing trouble for a lot of folks around here. When you try again, try installing rails 5.2.3 when it comes to that step in the installation guide:

gem install rails --version=5.2.3

That should allow you to bypass all the current woes until the curriculum is updated for the new rails version