Your first rails application


#1

Hello Team,

I am on a roll and progressing nicely with the Odin Project at URL https://www.theodinproject.com/courses/web-development-101/lessons/your-first-rails-application?ref=lnav. However, I got stuck at Step 3.5.1: Configure the Gemfile.

The instruction is to “Open your app in VSCode by typing code .” but when I do nothing happens, and I get the error message “-bash: code: command not found.” I am using a MacBook Pro running Mac Catalina version 10.15 Beta (19A546d).

I will appreciate any input to allow me to proceed.

Regards


How to open gemfile and what is gemfile
#2

I just completed this lesson (working on Ubuntu), and this was the part that really got my attention.

First off just want to clarify if you have VSCode installed from the app store?

Then second if you have it downloaded and set up, in the terminal are you typing ‘code .’ With the space between the period?


#3

Last question, did you confirm you were in the correct directory and use ‘ls’ to confirm the presence of gemfile in the directory?


#4

Thanks FranzYoseph for getting back to me quickly, this will help me keep the momentum. Yes I have installed VSCode but I did it within Terminal. Also I typed ‘code .’ with space between code and the period.

Should I have done it any different?

Regards


#5

I installed VSCode from the Linux app store equivalent but looking back at the text editors lesson TOP provides a link to download the VsCode app https://code.visualstudio.com/. If you haven’t done that yet, I think that may solve it.

VSCode also requires an extra step completed from within the app to be opened from the terminal on Mac. From the lesson:

MacOS Users: MacOS can do this too, but you need to set it up. After installing VSCode, launch it any way you’re comfortable with. Once it’s running, open the Command palette with CMD + Shift + P. In the little dialog that appears, type shell command. One of the choices that appears will be Shell Command: Install ‘code’ command in PATH. Select that option, and restart the terminal if you have it open.

After completing that step, VSCode should open when you enter the ‘code .’ Command from terminal.

Hope that helps!


#6

Right after responding to you, I begun to do some research. I have installed VsCode because clearly I had not done so before.

Either that to included in the steps till I had to use it or I overlooked it when following the process.

Everything seems to be running as planned

Thanks for your support, it is really appreciated.


#7

Glad to hear you’re back on track!