Your First Rails Application - Step 3.9


#1

So far I’ve followed the course step-by-step, with no errors, now when I go to open the app in heroku I’m told;
“We’re sorry, but something went wrong.
If you are the application owner check the logs for more information.”
Only thing I have done different is instead of using VSCode I am using Atom, which I have figured out that instead of typing “code” into the terminal I need to use “atom” (I think).
I have no idea where to look for resolving this issue, I just simply don’t get it, as we have been told will be the case.


#2

Type heroku logs in the terminal when in the rails project folder and see if you can spot an error in the logs.


#3

I am seeing a few errors, not sure if it’s on my end or what to do about them.

2020-02-04T17:43:17.182793+00:00 app[web.1]: I, [2020-02-04T17:43:17.182442 #4] INFO -- : [528afb59-9409-498c-8974-aad60fd3b670] Completed 500 Internal Server Error in 59ms 2020-02-04T17:43:17.185785+00:00 app[web.1]: F, [2020-02-04T17:43:17.185642 #4] FATAL -- : [528afb59-9409-498c-8974-aad60fd3b670] ActionView::Template::Error (FATAL: remaining connection slots are reserved for non-replication superuser connections 2020-02-04T17:43:17.186269+00:00 app[web.1]: F, [2020-02-04T17:43:17.186198 #4] FATAL -- : [528afb59-9409-498c-8974-aad60fd3b670] 2020-02-04T17:43:17.186393+00:00 app[web.1]: F, [2020-02-04T17:43:17.186318 #4] FATAL -- : [528afb59-9409-498c-8974-aad60fd3b670] app/views/cars/index.html.erb:16:in `_app_views_cars_index_html_erb__3575485685159875327_46921854739600' 2020-02-04T17:44:51.921515+00:00 app[web.1]: I, [2020-02-04T17:44:51.921385 #4] INFO -- : [6c57b456-0262-4eaa-aa95-c4034c02ec14] Completed 500 Internal Server Error in 44ms (ActiveRecord: 17.5ms) 2020-02-04T17:44:51.922290+00:00 app[web.1]: F, [2020-02-04T17:44:51.922211 #4] FATAL -- : [6c57b456-0262-4eaa-aa95-c4034c02ec14] ActionView::Template::Error (PG::UndefinedTable: ERROR: relation "cars" does not exist 2020-02-04T17:44:51.922462+00:00 app[web.1]: F, [2020-02-04T17:44:51.922399 #4] FATAL -- : [6c57b456-0262-4eaa-aa95-c4034c02ec14] 13: </thead> 2020-02-04T17:44:51.922534+00:00 app[web.1]: F, [2020-02-04T17:44:51.922462 #4] FATAL -- : [6c57b456-0262-4eaa-aa95-c4034c02ec14] 2020-02-04T17:44:51.922620+00:00 app[web.1]: F, [2020-02-04T17:44:51.922559 #4] FATAL -- : [6c57b456-0262-4eaa-aa95-c4034c02ec14] app/views/cars/index.html.erb:16:in `_app_views_cars_index_html_erb__3575485685159875327_46921854739600' 2020-02-04T18:19:28.249095+00:00 heroku[web.1]: Process exited with status 143

These are all the lines I see either either “Error” or “Fatal” in it, added “fatal” lines cause those can’t be good. Also added the last line stating the status, not sure what that means.

Would it be best for me to just start that lesson over?

And, thanks for getting back to me CouchofTomato, it’s greatly appreciated!


#4

No need to start again but I need to see more of the error

Copy everything after you type heroku logs into https://pastebin.com/ and then share it and paste the link here.


#5

I actually got it working! I ended up messing my whole system up trying to get ndiswrapper to work with my RTL8190, once I had the net819xp driver running my NetworkManager wasn’t working or responding. Ended up reinstalling ubuntu 18.04, went through the whole setup process (not bothering with ndiswrapper) and everything was working once I got to this point :slight_smile: