Your first rails app - error installing rails


#1

Hi everyone!
I’ve just started and I’ve been trying to follow the instructions as best I can while installing homebrew/ruby/etc, however, when it came to finally installing rails this error appeared.

User(me):$ gem install rails -v 5.2.3
   _ERROR:  Could not find a valid gem 'rails' (= 5.2.3), here is why:
   _          Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: tlsv1 alert protocol version (https://rubygems.org/specs.4.8.gz)

do I need to make an account on rubygems.org or something of the sort to be able to download from there?

I am using my old macbook running on yosemite 10.10.5


#2

Try gem update --system


#3

Hey Even I’m facing the same issue!
Can anyone kindly guide us what we’re supposed to do?

Thank you


#4

Hi @CouchofTomato I tried the command, heres what happened:

User(me):$ gem update --system
Latest version currently installed. Aborting.

and I tried to install rails again, same thing as initial post.


#5

you defo need a rubygems.org account. (-: