Web Dev 101: Installing Ruby Step 1.3 Failing


#1

Hi! I’m following along but can’t seem to install the required packages and libraries in step 1.3. I used the command:

sudo apt install curl git nodejs gcc make libssl-dev libreadline-dev zlib1g-dev libsqlite3-dev

And got this as a response in the terminal:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gcc : Depends: gcc-7 (>= 7.3.0-12~) but it is not going to be installed
libreadline-dev : Depends: libtinfo-dev but it is not going to be installed
libsqlite3-dev : Depends: libsqlite3-0 (= 3.22.0-1) but 3.22.0-1ubuntu0.3 is to be installed
libssl-dev : Depends: libssl1.1 (= 1.1.0g-2ubuntu4) but 1.1.1-1ubuntu2.1~18.04.5 is to be installed
Recommends: libssl-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Anyone know what’s causing this? I’ve followed every step to the letter up until this point. Running Xubuntu on a VirtualBox in Windows 10.