VM share folder issue


#1

Hello,

I am currently stuck in this course: https://www.theodinproject.com/courses/web-development-101/lessons/prerequisites?ref=lnav

To be more specific, I am stuck on step 3 of the “Virtual Machine (Recommended)” part.

I followed all of the guideline and managed to install a VM in my computer, installed guest additions and created a shared folder directory from “Devices”. But after all that, I can’t find my shared folder in my VM.

I had set the folder to be auto-mounted so I don’t think manually mounting the folder would make sense. I tried manually mounting the folder but it doesn’t seem to work at all. Is anyone else having the same issue?


#2

Do you get this error when you run the Guest Additions installer?

If so, you need to run the following commands in terminal:

sudo apt-get update
sudo apt-get install build-essential gcc make perl dkms
reboot

I was able to recreate your issue and ran the commands above, reinstalled the Guest Additions, and finally rebooted. My shared folders then showed up using the automount method in my virual machine share drive settings (no mount point defined).

Source: https://askubuntu.com/questions/1035030/virtualbox-guest-additions-installation-problem/1035043


#3

Hi thanks for helping out :slight_smile:

When I was installing guest additions I did run into some problems but not the same one you encountered. But I tried running through your commands anyway. But it seems I still can’t find the shared folder in my VM.

Maybe I don’t know where the folder location is. If you can see my screenshot, I can see the shared folder being active at the right bottom area but I don’t know how to access the folder. I can see the shared folder created in my host on Windows 10 but just not the other end.


#4

The shared folders should show up on the virtual machine’s desktop as drives. So if they’re not showing up then something is off.

I’m fairly certain this is because of those errors you’re getting when installing the Guest Additions drivers. Can you run the installer again and paste the log here?


#5

I created a new instance and reinstalled the guest additions just like you said and now it’s working. Thank you so much :smiley: