VirtualBox Error: Beginner, Please help


#1

Hello everyone,

Just a beginner here and this is my 2nd day of self-learning. Yesterday, the Virtual Box and Xubuntu were working fine and I was able to work in the Virtual Machine. Last night, I shut down my computer and was planning to continue today when the below error happens.

I could not open Xubuntu (Inaccessible it says). Please help me with this and what to do if the same problem occurs in the future. I tried googling and looking it here but it seems like other posts are different cases.

Failed to open the medium with following ID: {d5c28ac8-19d6-4b61-8bba-242054856618}. The given path ‘{d5c28ac8-19d6-4b61-8bba-242054856618}’ is not fully qualified. Result Code: VBOX_E_FILE_ERROR (0x80BB0004) Component: MediumWrap Interface: IMedium {ad47ad09-787b-44ab-b343-a082a3f2dfb1} Callee: IVirtualBox {d0a0163f-e254-4e5b-a1f2-011cf991c38d} Callee RC: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)


Virtualbox crashing
#2

Hi chimAEra,

Please try removing the .vdi image (Take note of where this file is located) from your VM, then try adding it back as a hard drive attachment.

No. 1 in the image is the location of the .vdi file. You will need to find this again.
No. 2 in the image is where you remove the hard drive attachment.
No. 3 in the image is where you add the file again from the Location you took note of in No. 1

If it doesn’t work, please could you attach the .vbox file. You can get to this file by right-clicking on the VM and selecting “Show in Explorer”


#3

Hey, I am having the same issue as above, but I cannot even click on the xubuntu not even to access the settings nor right click it. When I do, the vm produces the same error code and give infinite error prompts causing the vm to crash. Anyway around that? I also could not find a solution anywhere.

Thanks


#4

absolutely the same problem , do you fix it?


#5

I was able to resolve it only after I removed the xubuntu by deleting the entire xubuntu files.
On a Windows PC just go to C:\Users\YourUsername\VirtualBox VMs
Once you get there you can delete the Xubuntu folder entirely and just start the process over as you originally did creating the VM.


#6

Fix it, found decision in VirtualBox forum, here it is

  1. Launch “Activity Monitor.app”. Menu “View” » “All Processes” » click on the “Process Name” header to sort them by name.

  2. Quit VirtualBox. Then on the “Activity Monitor” make sure that there’s no “VBoxSVC” process.

  3. “Your disk” ▸ ⁨Users⁩ ▸ ⁨"Your user name" ▸ ⁨VirtualBox VMs⁩ ▸ Xubuntu ▸ Xuuntu.vbox with a text editor (TextWrangler, Atom, TextEdit). Delete the following 4 lines :
    <DVDImages> <Image uuid="{126dfdde-1b76-4dce-88a5-b1f30a893bb7}" location="/Users/user/Downloads/ubuntu-18.04.3-desktop-amd64.iso"/> <Image uuid="{0e3ca4cf-63fe-432c-aa09-079e300a8844}" location="/Applications/VirtualBox.app/Contents/MacOS/VBoxGuestAdditions.iso"/> </DVDImages>


#7

Awesome , thanks


#8

The solution provided by @sahion worked fine for me. Thanks a lot!


#9

I’m having the same exact issue and I tried your solution and it didn’t work. I’m on Windows 10. Anyone have a solution?


#10

If you’re not worried of losing anything you have on your vm you can try this. I am also on win 10 and solved it this way initially. You just have to make your vm again.


#11

I did that already and it did it again. I’d like to not have to create the vm again every time I turn it off.


#12

I’m fairly new to this, so I am not sure what else you could try. maybe someone else has another solution they can hopefully share. :persevere: