Ubuntu - VM - won't work, my computer isn't good enough


I have tried, and tried to install Ubuntu via VirtualBox but I think my computer just isn’t good enough for it.

Can I go through TOP without? I have Windows 10, unfortunately.


there are other options. have you tried installing the windows subsystem for linux? there are some cons to this but so far it has worked well for me with no problems but i’m not very far into the course. it goes over this in the installations portion of the lessons.


You can dual boot or switch completely to Linux. Have you tried using VM with xubuntu (A lightweight version of ubuntu that doesn’t eat up as much RAM and processing power as Ubuntu) ? Can you post your PC’s configuration ?


As @dvik1950 said, it might be worth looking into xubunut, or something even lighter. LIke Bodhi Linux. It is super light weight and even slow computers should be able to run it.

Also, have you increased the ram and processors allocated to the VM? This may be the solution.


I am downloading Xubuntu now. I will look into increasing the ram and processors.


I don’t have a very good computer. It’s what I could get with my current budget.


I just tried Xubuntu…what am I doing wrong?? ugh.

VB comes up with "This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for your CPU.

Also, I cannot choose an ubuntu 64bit operating system in VB as I do not have 64-bit options.


The issue you’re experiencing is because you do not have Virtualization enabled on your laptop, the good thing is your model does support it. All you have to do is go to the BIOS settings and mark ‘Virtualization Technology’ as enabled. Save the settings and restart your device after that.

I have a similar laptop with a slightly better processor, I’ve found that closing every app running on windows and using 75% of RAM and Processor cores for my VM works best. You can start at 50% and see how that goes.

Please let us know if you experience any more issues or if this for some reason doesn’t solve your problem. You can also visit the chat for a faster resposne. Good luck!


I have the same problem but I am unable to get into the BIOS for my laptop. it is a sony but I did have the hard drive replaced a while back. not sure if that is why I can’t get in.

Any suggestions on how to get to the BIOS? I tried many times using the ASSIST as instructed, i can’t get to the Viao screen that I need.

I am looking at just switching this computer over to linux completely.


VT-x/AMD-V hardware acceleration is not available on your system. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.

This is one of the warnings I get and I have been unsuccessful at turning it on.