Ubuntu 12.04.4?


#1

Hello again.

I have been scouring google, youtube, and reddit all day during the past 2 days trying to find solutions to my problems, but my (very limited) knowledge is only getting me so far. I can not for the life of me get the newest Ubuntu to work on Virtualbox. I believe this is because the computer that I am using is a Dell Optiplex 960. I downloaded the Hyper V feature on windows, and the necessary updates that came with that. I have also enabled the 3 virtualization settings on the BIOS after restarting the computer. I then completely shut off the computer, and turned it back on.

I have since tried using Windows Virtual PC and the only Ubuntu I can get running on that is 12.04.4. My question is, is this combo I have running now okay to use for The Odin Project / learning programming in general? Or am I just waisting my time with these? I apologize for being the probably the biggest noob on this site, and I am indebted to anyone that can help me. I want this more than I have wanted anything for a long time.


#2

Hi Tony,

How are you trying to install Ubuntu? Which versions have you tried? 12.04? 16.04? 14.04? 18.04? 32 or 64 bit versions?

Also, how are you trying to install the VM? As a Hypervisor? or inside of Virtualbox?

EDIT: Sorry - I just saw your previous post. Let me gather some info and give you a plan of attack


#3

Hi Tony,

Can you please confirm that you’re running a 64 bit version?

Go to the start menu > Right click on Computer > Properties

There should then be an area under the System section that says if your computer is 32 or 64-bit. See screenshot below where it says mine is 64 bit version of windows 7.

Once we have that figured out we can determine where to go from there!


#4

Here you go. Thank you for your willingness to help. :slight_smile:


#5

Wonderful :slight_smile:

You said you’ve installed Virtual Computer (Hyper-V) and I’m guessing you got the instructions from this page:
https://www.microsoft.com/en-us/download/details.aspx?id=3702

Unfortunately reading the fine print it says that Linux is not supported:

Guest: Windows XP Service Pack 3 (SP3) Professional, Windows Vista Enterprise Service Pack 1 (SP1), Windows Vista Ultimate Service Pack 1 (SP1), Windows Vista Business Service Pack 1 (SP1), Windows 7 Professional, Windows 7 Ultimate, Windows 7 Enterprise.

It would be best to uninstall the Virtual Computer program.

My guess is that you can uninstall it from the Control Panel > Uninstall a Program

Once that’s done, reboot your computer.

When you log back in, go to the Control Panel and search for “Windows Features” and then select “Turn Windows Features On or Off” from the menu. Please capture a screenshot of the entire window so I can make sure that you don’t have any virtualization systems installed. If there are, Virtual Box will only be able to use 32-bit versions.


#6

On it. Thank you sir.

EDIT: I actually didn’t install this particular file that you linked to. It was an update, I’ve attached a picture of said update file.


#7

Okay, so Windows Virtual PC didn’t show up under programs, so I looked under installed updates and found it there along with the update that I attached in my previous reply. I removed both of those.

image

I then rebooted, and when I logged back on I went to programs and features > Turn Windows features on or off, and took a shot of that window. I expanded any folder that was checked.


#8

Awesome -
Looks like we’re back at square one.

Let’s download a new copy of VirtualBox from here:

https://download.virtualbox.org/virtualbox/5.2.14/VirtualBox-5.2.14-123301-Win.exe

and make sure that we’ve downloaded the correct Ubuntu ISO file.

The name the ISO we want to install should be

ubuntu-18.04-desktop-amd64.iso

Note the amd64 suffix. This is the 64-bit version.

Can you please confirm these settings for me?


#9

Just got back into town, getting on this tomorrow AM.


#10

I figured I’d get it done real quick. These are the files I have downloaded.


#11

Looks good

Let’s install the new version of virtual box that you just downloaded and try once more to install a 64 bit version

If you don’t see the option please capture some screenshots and share them


#12

I don’t think you can use VirtualBox and Hyper-V at the same time. If you are using VirtualBox, you need to remove Hyper-V.


#13

21 days later, but I am finally able to dedicate more time to this. Thanks for bearing with me. I have installed VirtualBox, and am still only seeing 32 bit options. I also have Ubuntu x64 iso file installed but I am not seeing that either.


#14

I don’t believe I have hyper v installed.


#15

If VirtualBox is only showing 32 bit versions in the Version list make sure: Your Host OS is 64-bits. Intel Virtualization Technology and VT-d are both enabled in the BIOS. The Hyper-V platform is disabled in your Windows Feature list.