Stuck on the installation of the virtual machine


#1

Hi, I’m in the process of setting up a virtual machine. In one section of the install page of the Odin project website it states that:

“Next, go to the “Storage” tab and click the “Empty” CD icon. Select the Xubuntu iso file you downloaded earlier. If you aren’t sure where to find it, start by looking in your Downloads folder.”

So I went to the Storage tab and clicked on the empty CD icon. Nothing happens (see the image below). So what should I next?

Also, based on a few comments on this forum some people here seem to strongly recommend Linux/Windows dual boot instead of the Virtual machine. So I would like to know if that is the preferable route to go to. And also, what would be the worst pit falls in case that doesn’t go as intended.

Anyway, I won’t likely be able to respond to your comments in about 16 hours so please don’t take my silence for lack of appreciation.

Thanks for reading.


#2

Hi @japaz

Are you clicking on the CD over on the right next to the bit that says IDE secondary master?

Dual boot is usually recommended because a virtual machine has to split the resources of the computer running both windows and linux which can make it slower. I would think the worst that can happen is if you didn’t set up the dual boot correctly it could corrupt your windows install. I usually would suggest using a virtual machine until you are comfortable with using linux and then consider a dual boot.


#3

Thanks. I clicked on the CD next to “IDE secondary master” as you suggested and I was able to choose the Xubuntu Iso file.

Then I started the virtual machine and… nothing happens. There is only this black screen. It also doesn’t shut down when I try to close it. I need to do that from ctrl+alt+del.

I wonder if my computer is not powerful enough to run this. My Processor is Intel® Core™ i5-3570K CPU @ 3.40GHz. I have 12.0 Gb installed ram and a 64-bit operating system. Also, was I meant to extract the Xubuntu iso file before selecting it in the Storage tab of the System menu?

This is a screenshot of my Virtual Box settings:


#4

No, you don’t need to extract the ISO.

Your computer definitely is good enough to run it. How long was it in the black screen state for before you shut it down?


#5

Okay, that is good to know.

I waited several minutes and the black screen state didn’t change. And whenever I tried to shut it down, the virtual machine became unresponsive and I had to close it from ctrl+alt+del.


#6

One more question.

Do you see anything before the black screen loads or did it just jump straight to that?


#7

Yes. I briefly see the screen that appears in this video https://youtu.be/sc-kHLUn_9E (at 9:07).

Except I think that the background color for it was green instead of black.

I think I pressed F12 once when it appeared but nothing happened.


#8

Did you enable virtualization in the bios settings of your pc ok and saved the changes?


#9

Yes I first enabled virtualization from bios. After this I wasn’t yet able to increase the amount of processors in virtual box system settings. Then, after following instructions in this link I was able to do that.

I also created a virtual switch button as was advised in this article. I have no idea what that does.

Now when I started the virtual machine and pressed F12 the screen below appeared. Am I suppose to continue from here? When I tried a second time to start the virtual machine, again the black screen stayed there and nothing else happened.


#10

Maybe try downloading a fresh xubuntu install, or you can try regular ubuntu just to see if a different iso does anything different.


#11

Thanks. I will try that.


#12

Hi again, I tried reinstalling Xubuntu and also regular Ubuntu but those didn’t work.

Then, on one forum someone advised to disable Hyper-V from Windows settings.

image

So this is what I did. For the first time I was able to start the installation for Xubuntu. I didn’t try to get further yet. Do you have any idea why this is, and is it okay to leave Hyper-V disabled for good.

EDIT:

I found an article stating that you cannot run Hyper-V and Virtual Box at the same time.

I would recommend The Odin Project creators to mention this for people like me who are clueless about these issues.

On your website it states:

“Click on the “System” tab and then the “Processor” tab. Increase the Processor(s) to 2. If this screen prevents you from increasing processors, you likely need to enable virtualization in your computer’s BIOS/UEFI settings.

That last link takes you to a google search and the first result is this. This also the instruction that I followed for enabling virtualization.