Stuck on the gem sqlite3 change in the first_rails_app project (Mac)


#1

Okay, so right after I ‘cd my_first_rails_app’ the next step is to enter ‘rails generate scaffold car make:string model:string year:integer’ into the terminal. I then get the error code:
rails aborted!
LoadError: Error loading the ‘sqlite3’ Active Record adapter. Missing a gem it depends on? can’t activate sqlite3 (~> 1.3.6), already activated sqlite3-1.4.0. Make sure all dependencies are added to Gemfile.
/Users/palmi/odin_on_rails/my_first_rails_app/bin/rails:9:in <top (required)>' /Users/palmi/odin_on_rails/my_first_rails_app/bin/spring:15:in<top (required)>’
bin/rails:3:in load' bin/rails:3:in

So it then says that if i receive this error code I should type ‘code Gemfile’ into the terminal, but when I do so I get this:
-bash: code: command not found

Sorry, I am a total noob at this… Any ideas?


#2

Looks like you missed a step.

Follow the bit here on launching from the command line.


#3

This worked, thank you.