Step 3.7 Common problem, but none of the solutions are working for me! Halp please


#1

Ok, I have been perusing forums for an hour and a half. I am somewhat a NooB. I am finding numerous posts about this problem, but none of the solutions are working for me. I tried re-doing all of the steps in case I missed something but no go. Still getting the same error message. Any help would be greatly appreciated. I would love to get back on track for learning this!!! Thank you in advance all.

git push heroku master
Counting objects: 122, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (107/107), done.
Writing objects: 100% (122/122), 27.37 KiB | 2.11 MiB/s, done.
Total 122 (delta 10), reused 0 (delta 0)
remote: Compressing source files... done.
remote: Building source:
remote: 
remote:  !     Warning: Multiple default buildpacks reported the ability to handle this app. The first buildpack in the list below will be used.
remote: 			Detected buildpacks: Ruby,Node.js
remote: 			See https://devcenter.heroku.com/articles/buildpacks#buildpack-detect-order
remote: -----> Ruby app detected
remote: -----> Compiling Ruby/Rails
remote: -----> Using Ruby version: ruby-2.6.4
remote: -----> Installing dependencies using bundler 1.17.3
remote:        Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
remote:        The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
remote:        Fetching gem metadata from https://rubygems.org/............
remote:        Fetching rake 13.0.0
remote:        Installing rake 13.0.0
remote:        Fetching concurrent-ruby 1.1.5
remote:        Fetching minitest 5.12.2
remote:        Fetching thread_safe 0.3.6
remote:        Installing minitest 5.12.2
remote:        Installing thread_safe 0.3.6
remote:        Installing concurrent-ruby 1.1.5
remote:        Fetching builder 3.2.3
remote:        Installing builder 3.2.3
remote:        Fetching erubi 1.9.0
remote:        Installing erubi 1.9.0
remote:        Fetching mini_portile2 2.4.0
remote:        Fetching crass 1.0.5
remote:        Installing mini_portile2 2.4.0
remote:        Installing crass 1.0.5
remote:        Fetching rack 2.0.7
remote:        Fetching nio4r 2.5.2
remote:        Installing nio4r 2.5.2 with native extensions
remote:        Installing rack 2.0.7
remote:        Fetching websocket-extensions 0.1.4
remote:        Installing websocket-extensions 0.1.4
remote:        Fetching mini_mime 1.0.2
remote:        Installing mini_mime 1.0.2
remote:        Fetching arel 9.0.0
remote:        Installing arel 9.0.0
remote:        Fetching mimemagic 0.3.3
remote:        Fetching msgpack 1.3.1
remote:        Installing mimemagic 0.3.3
remote:        Installing msgpack 1.3.1 with native extensions
remote:        Using bundler 1.17.3
remote:        Fetching coffee-script-source 1.12.2
remote:        Installing coffee-script-source 1.12.2
remote:        Fetching execjs 2.7.0
remote:        Installing execjs 2.7.0
remote:        Fetching method_source 0.9.2
remote:        Installing method_source 0.9.2
remote:        Fetching thor 0.20.3
remote:        Installing thor 0.20.3
remote:        Fetching ffi 1.11.1
remote:        Installing ffi 1.11.1 with native extensions
remote:        Fetching pg 1.1.4
remote:        Installing pg 1.1.4 with native extensions
remote:        Fetching puma 3.12.1
remote:        Installing puma 3.12.1 with native extensions
remote:        Fetching rb-fsevent 0.10.3
remote:        Installing rb-fsevent 0.10.3
remote:        Fetching tilt 2.0.10
remote:        Installing tilt 2.0.10
remote:        Fetching turbolinks-source 5.2.0
remote:        Installing turbolinks-source 5.2.0
remote:        Fetching tzinfo 1.2.5
remote:        Installing tzinfo 1.2.5
remote:        Fetching nokogiri 1.10.4
remote:        Installing nokogiri 1.10.4 with native extensions
remote:        Fetching i18n 1.7.0
remote:        Installing i18n 1.7.0
remote:        Fetching websocket-driver 0.7.1
remote:        Installing websocket-driver 0.7.1 with native extensions
remote:        Fetching mail 2.7.1
remote:        Installing mail 2.7.1
remote:        Fetching rack-test 1.1.0
remote:        Installing rack-test 1.1.0
remote:        Fetching sprockets 3.7.2
remote:        Installing sprockets 3.7.2
remote:        Fetching marcel 0.3.3
remote:        Installing marcel 0.3.3
remote:        Fetching coffee-script 2.4.1
remote:        Installing coffee-script 2.4.1
remote:        Fetching uglifier 4.2.0
remote:        Installing uglifier 4.2.0
remote:        Fetching bootsnap 1.4.5
remote:        Installing bootsnap 1.4.5 with native extensions
remote:        Fetching rb-inotify 0.10.0
remote:        Installing rb-inotify 0.10.0
remote:        Fetching turbolinks 5.2.1
remote:        Installing turbolinks 5.2.1
remote:        Fetching activesupport 5.2.3
remote:        Installing activesupport 5.2.3
remote:        Fetching loofah 2.3.1
remote:        Installing loofah 2.3.1
remote:        Fetching sass-listen 4.0.0
remote:        Installing sass-listen 4.0.0
remote:        Fetching rails-dom-testing 2.0.3
remote:        Installing rails-dom-testing 2.0.3
remote:        Fetching globalid 0.4.2
remote:        Installing globalid 0.4.2
remote:        Fetching activemodel 5.2.3
remote:        Installing activemodel 5.2.3
remote:        Fetching jbuilder 2.9.1
remote:        Installing jbuilder 2.9.1
remote:        Fetching rails-html-sanitizer 1.3.0
remote:        Installing rails-html-sanitizer 1.3.0
remote:        Fetching activejob 5.2.3
remote:        Fetching sass 3.7.4
remote:        Installing activejob 5.2.3
remote:        Installing sass 3.7.4
remote:        Fetching activerecord 5.2.3
remote:        Fetching actionview 5.2.3
remote:        Installing activerecord 5.2.3
remote:        Installing actionview 5.2.3
remote:        Fetching actionpack 5.2.3
remote:        Installing actionpack 5.2.3
remote:        Fetching actioncable 5.2.3
remote:        Fetching activestorage 5.2.3
remote:        Fetching actionmailer 5.2.3
remote:        Installing activestorage 5.2.3
remote:        Installing actionmailer 5.2.3
remote:        Installing actioncable 5.2.3
remote:        Fetching railties 5.2.3
remote:        Installing railties 5.2.3
remote:        Fetching sprockets-rails 3.2.1
remote:        Installing sprockets-rails 3.2.1
remote:        Fetching coffee-rails 4.2.2
remote:        Fetching sass-rails 5.1.0
remote:        Fetching rails 5.2.3
remote:        Installing coffee-rails 4.2.2
remote:        Installing sass-rails 5.1.0
remote:        Installing rails 5.2.3
remote:        Bundle complete! 19 Gemfile dependencies, 60 gems now installed.
remote:        Gems in the groups development and test were not installed.
remote:        Bundled gems are installed into `./vendor/bundle`
remote:        Post-install message from i18n:
remote:        
remote:        HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
remote:        But that may break your application.
remote:        
remote:        Please check your Rails app for 'config.i18n.fallbacks = true'.
remote:        If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
remote:        'config.i18n.fallbacks = [I18n.default_locale]'.
remote:        If not, fallbacks will be broken in your app by I18n 1.1.x.
remote:        
remote:        For more info see:
remote:        https://github.com/svenfuchs/i18n/releases/tag/v1.1.0
remote:        
remote:        Post-install message from sass:
remote:        
remote:        Ruby Sass has reached end-of-life and should no longer be used.
remote:        
remote:        * If you use Sass as a command-line tool, we recommend using Dart Sass, the new
remote:          primary implementation: https://sass-lang.com/install
remote:        
remote:        * If you use Sass as a plug-in for a Ruby web framework, we recommend using the
remote:          sassc gem: https://github.com/sass/sassc-ruby#readme
remote:        
remote:        * For more details, please refer to the Sass blog:
remote:          https://sass-lang.com/blog/posts/7828841
remote:        
remote:        Bundle completed (44.41s)
remote:        Cleaning up the bundler cache.
remote:        The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
remote: -----> Installing node-v10.15.3-linux-x64
remote: -----> Detecting rake tasks
remote: -----> Preparing app for Rails asset pipeline
remote:        Running: rake assets:precompile
remote:        rake aborted!
remote:        SyntaxError: /tmp/build_46f721bbb87b64187cb93fd257029a8b/config/routes.rb:8: syntax error, unexpected end, expecting end-of-input
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:54:in `load'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:54:in `load'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:285:in `block in load'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:257:in `load_dependency'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:285:in `load'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application/routes_reloader.rb:41:in `block in load_paths'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application/routes_reloader.rb:41:in `each'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application/routes_reloader.rb:41:in `load_paths'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application/routes_reloader.rb:20:in `reload!'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application/routes_reloader.rb:30:in `block in updater'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/file_update_checker.rb:83:in `execute'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application/routes_reloader.rb:10:in `execute'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application/finisher.rb:130:in `block in <module:Finisher>'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/initializable.rb:32:in `instance_exec'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/initializable.rb:32:in `run'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/initializable.rb:61:in `block in run_initializers'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/initializable.rb:60:in `run_initializers'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application.rb:361:in `initialize!'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/config/environment.rb:5:in `<main>'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `require'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:22:in `block in require_with_bootsnap_lfi'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/loaded_features_index.rb:92:in `register'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require_with_bootsnap_lfi'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:30:in `require'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `block in require'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:257:in `load_dependency'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.3/lib/active_support/dependencies.rb:291:in `require'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application.rb:337:in `require_environment!'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/railties-5.2.3/lib/rails/application.rb:520:in `block in run_tasks_blocks'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:62:in `block (2 levels) in define'
remote:        /tmp/build_46f721bbb87b64187cb93fd257029a8b/vendor/bundle/ruby/2.6.0/gems/rake-13.0.0/exe/rake:27:in `<top (required)>'
remote:        Tasks: TOP => environment
remote:        (See full trace by running task with --trace)
remote: 
remote:  !
remote:  !     Precompiling assets failed.
remote:  !
remote:  !     Push rejected, failed to compile Ruby app.
remote: 
remote:  !     Push failed
remote: Verifying deploy...
remote: 
remote: !	Push rejected to agile-basin-08688.
remote: 
To https://git.heroku.com/agile-basin-08688.git
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https://git.heroku.com/agile-basin-08688.git'
jespody@jespody-Surface-Pro-3:~/JessTOP/my_first_rails_app$

#2

You have a syntax error in your routes.rb file

It’s in the config directory. Looks like you’ve added an extra end statement in there. Once you fix that you’ll need to git add, commit and push to heroku again.