Step 1.4 CarsController#index is missing a template for request formats: text/html


#21

Actually don’t do that. One moment.


#22

Can you start a rails server and try the following addresses in your browser:

http://127.0.01:3000
http://127.0.01:3030
http://locahost:3030

#23

I can only connect to the first one http://127.0.01:3000
It shows the “Yay you’re on Rails” page


#24

Sorry try http://127.0.01:3000/cars


#25

Right of course, I get the same error message


#26

hmmm.

Does [::1]:3000/cars in your browser do anything different?


#27

Hmm interesting it seems to work now. Although so does localhost:3000/cars

I’m not sure what changed


#28

Actually, I wonder if it was some issue with my file names/structure. I was keeping the project within a folder called Documents (Local) and I moved it into my home folder. Maybe the parentheses could’ve have messed something up, but otherwise I have no idea


#29

Sometimes spaces in a filename can mess things up


#30

Lesson learned. Thanks for the help!


#31

I had the same issue while on my windows os. Turns out whenever i run the rails s command in powershell, i get thata error, but with cmd and git i dont get that error. So the simple solution was to change to cmd