Sqlite3 error when trying to migrate the database (2.3 First rails app)


#21

I’m using Ubuntu 18.04 and ran into the same problem but @1stevengrant’s solution also worked for me.
Thank you!


#22

Hi @bbates22, I’m using Ubuntu and was able to edit the Gemfile by:

  1. using cd to enter the directory that the app is in (for me it was cd odin_on_rails/my_first_rails_app)
  2. using ls -a to list the files in the directory and make sure the Gemfile was present
  3. using xdg-open Gemfile to open the Gemfile (you may need to use a different command depending on your OS)
  4. in the Gemfile, use “ctrl+f” to locate 'sqlite3' and change it as @1stevengrant suggested

hope this helps


#23

I opened the my_first_rails_app and have opened the gem file document. What specifically do I change?


#24

as described above, by @1stevengrant

change gem 'sqlite3' to gem 'sqlite3', '~> 1.3.6' in the Gemfile (and save the file)

then run bundle install again.


#25

I got it! Thank you! Still pretty new to this. Thank you for the help. Good learning experience


#26

This ended up making my project work. I was stuck on this for about an hour. Thank you so much!


#27

thanks for this, i was wondering how to open the gemfile, only to later on realise they explain it to you further down the line in Step 4.5.1: Configure the Gemfile of PROJECT: YOUR FIRST RAILS APPLICATION


#28

This helped perfectly. Thank you!


#29

All your steps are a life saver! I had the same errors and was able to fix it using your solution.


#30

This worked for me. I had the same issue the others described, and this specific process worked perfectly on my Xubuntu VM. Thank you!


#31

Thank you so much! I was feeling so lost until I saw your comment.