(SOLVED) Web Dev 101. Project Your First Rails App. Error when deploying/migrating to Heroku


#1

Hi guys! I’m new to the course, and I’ve run into some trouble with the heroku setup in the Web Dev 101 - Your First Rails App.
In Step 3.8: Migrate the Database on Heroku
When I type in:

heroku run rails db:migrate

I get this output:

Running rails db:migrate on ⬢ stormy-garden-72571... up, run.5094 (Free)
bash: rails: command not found

And on the heroku site, on the app page it says:

“Heroku | Welcome to your new app!
Refer to the documentation if you need help deploying.”

All worked just fine until this point.
I’m running this on Pop OS with everything updated.

Can someone Help me?

Thanks!


EDIT: This gets solved by doing what it says in the lesson:

UPDATE 2019-01-04: If you run into an error on the next command stating that you need to use Bundler 2 or greater with this lockfile, you’ll need to run:

heroku buildpacks:set https://github.com/bundler/heroku-buildpack-bundler2

and then run the git push heroku master command again.