[Solved] Unable to Install Guest Additions


#1

Hello,

I am brand new and going through the VM installations and am getting an error when trying to install the Guest Additions. I followed this guide - https://www.theodinproject.com/lessons/prerequisites which seemed to work fine to install the VM and Linux, but when I followed this guide https://www.youtube.com/watch?v=qNecdUsuTPw for the Guest Additions it gives me this error:

image

Thank you!


#2

Hi There,

I have been struggling with the same thing yesterday (hours of google search, even downloaded servers on both host and guest to transfer files, but couldn’t make it work).

The problem for me that the ISO file is automatically mounted already, and its read-only for some reason when I open it from Desktop (first time Linux user here, so that might be normal) There are suggestions to dismount the drive first then it will start automatically… It might work for you if you try to dismount the ISO, restart and then try to click on “Insert Guest Addition CD Image”. more on that here.

What worked for me:

  1. I have opened the mounted CD from the Guest desktop (you should see a CD icon there)
  2. When you are in file manager right click anywhere in the folder and select “open terminal here” option
  3. Run the command below
    $ sudo sh ./VBoxLinuxAdditions.run
    note: I have only seen read-only exe-s, but i gave it a go anyway and it worked!
  4. Type in your password and wait until it installs.
    5 Restart your system.

Hope this helps!


#3

Hi! This worked great!

That was exactly my problem. It was mounted and read only. The tutorial had it running automatically but mine wouldn’t and I couldn’t figure it out. The terminal command worked and after resetting everything the guest additions seem to be working.

Thanks again!


#4

i tried this and i got an error codeubuntu%20error. pls help I’ve spent days tried to make it work


#5

Hi there! I think you are not in the mounted disk folder, can you see the mounted disk in your desktop? You have to open the terminal from there (right click in folder)