(SOLVED)Seeking help with Step 4.7: Push to Heroku


#1

Hi guys,

I am seeking help for getting my First Rails App unto Heroku. I tried a couple of different things but without result. the code i get is:

Counting objects: 118, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (103/103), done.
Writing objects: 100% (118/118), 27.15 KiB | 1.13 MiB/s, done.
Total 118 (delta 7), reused 0 (delta 0)
remote: Compressing source files… done.
remote: Building source:
remote:
remote: ! Warning: Multiple default buildpacks reported the ability to handle this app. The first buildpack in the list below will be used.
remote: Detected buildpacks: Ruby,Node.js
remote: See https://devcenter.heroku.com/articles/buildpacks#buildpack-detect-order
remote: -----> Ruby app detected
remote: -----> Compiling Ruby/Rails
remote: -----> Using Ruby version: ruby-2.6.0
remote: -----> Installing dependencies using bundler 1.15.2
remote: Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
remote: The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java.
remote: Fetching gem metadata from https://rubygems.org/
remote: Fetching rake 12.3.2
remote: Installing rake 12.3.2
remote: Fetching concurrent-ruby 1.1.4
remote: Fetching minitest 5.11.3
remote: Fetching thread_safe 0.3.6
remote: Installing minitest 5.11.3
remote: Installing thread_safe 0.3.6
remote: Installing concurrent-ruby 1.1.4
remote: Fetching builder 3.2.3
remote: Installing builder 3.2.3
remote: Fetching erubi 1.8.0
remote: Installing erubi 1.8.0
remote: Fetching mini_portile2 2.4.0
remote: Fetching crass 1.0.4
remote: Installing mini_portile2 2.4.0
remote: Installing crass 1.0.4
remote: Fetching rack 2.0.6
remote: Fetching nio4r 2.3.1
remote: Installing nio4r 2.3.1 with native extensions
remote: Installing rack 2.0.6
remote: Fetching websocket-extensions 0.1.3
remote: Installing websocket-extensions 0.1.3
remote: Fetching mini_mime 1.0.1
remote: Installing mini_mime 1.0.1
remote: Fetching arel 9.0.0
remote: Installing arel 9.0.0
remote: Fetching mimemagic 0.3.3
remote: Fetching msgpack 1.2.6
remote: Installing msgpack 1.2.6 with native extensions
remote: Installing mimemagic 0.3.3
remote: Using bundler 1.17.2
remote: Fetching coffee-script-source 1.12.2
remote: Installing coffee-script-source 1.12.2
remote: Fetching execjs 2.7.0
remote: Installing execjs 2.7.0
remote: Fetching method_source 0.9.2
remote: Installing method_source 0.9.2
remote: Fetching thor 0.20.3
remote: Installing thor 0.20.3
remote: Fetching ffi 1.10.0
remote: Installing ffi 1.10.0 with native extensions
remote: Fetching multi_json 1.13.1
remote: Installing multi_json 1.13.1
remote: Fetching pg 1.1.4
remote: Installing pg 1.1.4 with native extensions
remote: Fetching puma 3.12.0
remote: Installing puma 3.12.0 with native extensions
remote: Fetching rb-fsevent 0.10.3
remote: Installing rb-fsevent 0.10.3
remote: Fetching tilt 2.0.9
remote: Installing tilt 2.0.9
remote: Fetching turbolinks-source 5.2.0
remote: Installing turbolinks-source 5.2.0
remote: Fetching tzinfo 1.2.5
remote: Installing tzinfo 1.2.5
remote: Fetching nokogiri 1.10.1
remote: Installing nokogiri 1.10.1 with native extensions
remote: Fetching i18n 1.5.3
remote: Installing i18n 1.5.3
remote: Fetching websocket-driver 0.7.0
remote: Installing websocket-driver 0.7.0 with native extensions
remote: Fetching mail 2.7.1
remote: Installing mail 2.7.1
remote: Fetching rack-test 1.1.0
remote: Installing rack-test 1.1.0
remote: Fetching sprockets 3.7.2
remote: Installing sprockets 3.7.2
remote: Fetching marcel 0.3.3
remote: Installing marcel 0.3.3
remote: Fetching coffee-script 2.4.1
remote: Installing coffee-script 2.4.1
remote: Fetching uglifier 4.1.20
remote: Installing uglifier 4.1.20
remote: Fetching bootsnap 1.4.0
remote: Installing bootsnap 1.4.0 with native extensions
remote: Fetching rb-inotify 0.10.0
remote: Installing rb-inotify 0.10.0
remote: Fetching turbolinks 5.2.0
remote: Installing turbolinks 5.2.0
remote: Fetching activesupport 5.2.2
remote: Installing activesupport 5.2.2
remote: Fetching loofah 2.2.3
remote: Fetching sass-listen 4.0.0
remote: Installing loofah 2.2.3
remote: Installing sass-listen 4.0.0
remote: Fetching rails-dom-testing 2.0.3
remote: Installing rails-dom-testing 2.0.3
remote: Fetching globalid 0.4.2
remote: Installing globalid 0.4.2
remote: Fetching activemodel 5.2.2
remote: Fetching jbuilder 2.8.0
remote: Installing activemodel 5.2.2
remote: Installing jbuilder 2.8.0
remote: Fetching sass 3.7.3
remote: Fetching rails-html-sanitizer 1.0.4
remote: Installing rails-html-sanitizer 1.0.4
remote: Installing sass 3.7.3
remote: Fetching activejob 5.2.2
remote: Installing activejob 5.2.2
remote: Fetching activerecord 5.2.2
remote: Installing activerecord 5.2.2
remote: Fetching actionview 5.2.2
remote: Installing actionview 5.2.2
remote: Fetching actionpack 5.2.2
remote: Installing actionpack 5.2.2
remote: Fetching actioncable 5.2.2
remote: Fetching actionmailer 5.2.2
remote: Fetching activestorage 5.2.2
remote: Installing actioncable 5.2.2
remote: Installing activestorage 5.2.2
remote: Installing actionmailer 5.2.2
remote: Fetching railties 5.2.2
remote: Fetching sprockets-rails 3.2.1
remote: Installing railties 5.2.2
remote: Installing sprockets-rails 3.2.1
remote: Fetching coffee-rails 4.2.2
remote: Fetching rails 5.2.2
remote: Fetching sass-rails 5.0.7
remote: Installing coffee-rails 4.2.2
remote: Installing sass-rails 5.0.7
remote: Installing rails 5.2.2
remote: Bundle complete! 19 Gemfile dependencies, 61 gems now installed.
remote: Gems in the groups development and test were not installed.
remote: Bundled gems are installed into ./vendor/bundle
remote: Post-install message from i18n:
remote:
remote: HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
remote: But that may break your application.
remote:
remote: Please check your Rails app for ‘config.i18n.fallbacks = true’.
remote: If you’re using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
remote: ‘config.i18n.fallbacks = [I18n.default_locale]’.
remote: If not, fallbacks will be broken in your app by I18n 1.1.x.
remote:
remote: For more info see:
remote: https://github.com/svenfuchs/i18n/releases/tag/v1.1.0
remote:
remote: Post-install message from sass:
remote:
remote: Ruby Sass is deprecated and will be unmaintained as of 26 March 2019.
remote:
remote: * If you use Sass as a command-line tool, we recommend using Dart Sass, the new
remote: primary implementation: https://sass-lang.com/install
remote:
remote: * If you use Sass as a plug-in for a Ruby web framework, we recommend using the
remote: sassc gem: https://github.com/sass/sassc-ruby#readme
remote:
remote: * For more details, please refer to the Sass blog:
remote: http://sass.logdown.com/posts/7081811
remote:
remote: Removing bundler (1.15.2)
remote: Bundle completed (42.82s)
remote: Cleaning up the bundler cache.
remote: The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java.
remote: -----> Installing node-v10.14.1-linux-x64
remote: -----> Detecting rake tasks
remote: -----> Preparing app for Rails asset pipeline
remote: Running: rake assets:precompile
remote: Yarn executable was not detected in the system.
remote: Download Yarn at https://yarnpkg.com/en/docs/install
remote: I, [2019-02-23T06:54:25.476558 #1312] INFO – : Writing /tmp/build_8f52b5ee569a7b68a0349899c4f22545/public/assets/application-9622f0fe63bfad91bdeaa3a771e86262263840678fd66849b311b6cfb3f7cc85.js
remote: I, [2019-02-23T06:54:25.477234 #1312] INFO – : Writing /tmp/build_8f52b5ee569a7b68a0349899c4f22545/public/assets/application-9622f0fe63bfad91bdeaa3a771e86262263840678fd66849b311b6cfb3f7cc85.js.gz
remote: I, [2019-02-23T06:54:25.512758 #1312] INFO – : Writing /tmp/build_8f52b5ee569a7b68a0349899c4f22545/public/assets/application-35729bfbaf9967f119234595ed222f7ab14859f304ab0acc5451afb387f637fa.css
remote: I, [2019-02-23T06:54:25.513203 #1312] INFO – : Writing /tmp/build_8f52b5ee569a7b68a0349899c4f22545/public/assets/application-35729bfbaf9967f119234595ed222f7ab14859f304ab0acc5451afb387f637fa.css.gz
remote: Asset precompilation completed (3.71s)
remote: Cleaning assets
remote: Running: rake assets:clean
remote: -----> Detecting rails configuration
remote:
remote: ###### WARNING:
remote:
remote: Detecting rails configuration failed
remote: set HEROKU_DEBUG_RAILS_RUNNER=1 to debug
remote:
remote: ###### WARNING:
remote:
remote: We detected that some binary dependencies required to
remote: use all the preview features of Active Storage are not
remote: present on this system.
remote:
remote: For more information please see:
remote: https://devcenter.heroku.com/articles/active-storage-on-heroku
remote:
remote:
remote: ###### WARNING:
remote:
remote: No Procfile detected, using the default web server.
remote: We recommend explicitly declaring how to boot your server process via a Procfile.
remote: https://devcenter.heroku.com/articles/ruby-default-web-server
remote:
remote:
remote: -----> Discovering process types
remote: Procfile declares types -> (none)
remote: Default types for buildpack -> console, rake, web
remote:
remote: -----> Compressing…
remote: Done: 42M
remote: -----> Launching…
remote: Released v6
remote: https://shrouded-island-30352.herokuapp.com/ deployed to Heroku
remote:
remote: Verifying deploy… done.
To https://git.heroku.com/shrouded-island-30352.git

  • [new branch] master -> master

When i open the site, it says:

We’re sorry, but something went wrong.

If you are the application owner check the logs for more information.

could somebody help or give advice? Thanks TOP!


#2

In the rails directory in your terminal type heroku logs and see if it shows you an error.


#3

Also https://shrouded-island-30352.herokuapp.com/ this appears to be working for me


#4

Thank you so much for the reaction @CouchofTomato & sorry for the late response. I did not see that you responded to the problem.

I did get it to work. Thanks again :slight_smile: