[SOLVED] Push to Heroku


#1

Hi guys

I run into problems installing the bundle mentioned in the update. Checked all similar questions, but don’t see any output like mine - “missing required flag”?

Edit: Looks like I need to name the app, but when I try to do that, I get the same message again.

UPDATE 2019-01-04: If you run into an error on the next command stating that you need to use Bundler 2 or greater with this lockfile, you’ll need to run:

heroku buildpacks:set https://github.com/bundler/heroku-buildpack-bundler2


#2

I thought you didn’t need to set the buildpack anymore.


#3

Well, I had the error, so figured I have to do that…


#4

What error?


#5

The one asking for the bundle :slight_smile:


#6

As you can see here in teh readme they no longer maintain it because heroku now supports bundler2.

Can I see a screenshot of the error please.


#7

I just checked again and getting a different message. Looks like I’m missing something but followed all the steps literally. Sorry, have no idea what I am doing :confused:

image


#8

That’s the expected output of git status.

What error are you getting?


#9

Not sure if it’s an error but I don’t see any files to be added, like here and nothing happens when I run git add .


#10

You can’t just run git add. You need to list the files. If you want to just add all files that have changed use git add . with the full stop


#11

yes, that’s what I did… the full stop jumped to the next line in my message


#12

So you get no feedback at all when you use git add?


#13

Nope… git remote show - also returns origin instead of heroku now

And when I tried some of the other commands… I’m totally lost now

banan4@banan4-VirtualBox:~/Documents/odin_on_rails/my_first_rails_app$ git push origin master
Warning: Permanently added the RSA host key for IP address ‘192.30.253.113’ to the list of known hosts.
Everything up-to-date
banan4@banan4-VirtualBox:~/Documents/odin_on_rails/my_first_rails_app$ git push heroku master
fatal: ‘heroku’ does not appear to be a git repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.


#14

And you haven’t changed the directory in the terminal?


#15

No, still at ~/Documents/odin_on_rails/my_first_rails_app


#16

What’s the output of ls -a


#17

. .bundle Gemfile lib Rakefile test
… config Gemfile.lock log README.md tmp
app config.ru .git package.json .ruby-version vendor
bin db .gitignore public storage


#18

Ok, show me the output of the following please.

git status
git remote -v
git diff

#19

banan4@banan4-VirtualBox:~/Documents/odin_on_rails/my_first_rails_app$ git status
On branch master
Your branch is up to date with ‘origin/master’.

nothing to commit, working tree clean
banan4@banan4-VirtualBox:~/Documents/odin_on_rails/my_first_rails_app$ git remote -v
origin git@github.com:aborisova19/my_first_rails_app.git (fetch)
origin git@github.com:aborisova19/my_first_rails_app.git (push)
banan4@banan4-VirtualBox:~/Documents/odin_on_rails/my_first_rails_app$ git diff

No output on the last one…


#20

Ok so what if you do heroku create