Setting up my development environment


#1

Hello all, as the topic of my message says I’m installing the packages and libraries in my computer in order to start the course. however I’ve encountered a couple of errors and I’d like a bit of feedback before moving on.

At first, when I tried to install Xcode by using ‘xcode-select --install’ I’ve got this message: ‘command line tools are already installed, use “Software Update” to install updates’. So before asking for help I searched in some forums like the one from Stack Overflow and some people had the same issue.

Some of the advices were to look for updates of the program as it was already installed with ‘softwareupdate --list’ but as it didn’t showed up in the list I followed someone else’s advise and removed all the old tools by running ‘$ rm -rf /Library/Developer/CommandLineTools’ which gave me a massive list of programs that were denied to be removed. Something like this:

‘rm: /Library/Developer/CommandLineTools/usr/bin/indent: Permission denied
rm: /Library/Developer/CommandLineTools/usr/bin/xml2man: Permission denied
rm: /Library/Developer/CommandLineTools/usr/bin/gcov: Permission denied
rm: /Library/Developer/CommandLineTools/usr/bin/svn: Permission denied
rm: /Library/Developer/CommandLineTools/usr/bin/g++: Permission denied
rm: /Library/Developer/CommandLineTools/usr/bin/libtool: Permission denied
rm: /Library/Developer/CommandLineTools/usr/bin/Rez: Permission denied
rm: /Library/Developer/CommandLineTools/usr/bin/svnserve: Permission denied’

Xcode was included in all of them. As I didn’t know what to do I kept going and installed Homebrew folloging TOP instructions and it went just fine, tried to check again with the list uf updates and still xcode or homebrew were not in that list, so tried to instal xcode again with no luck. Finally I tried to update xcode with ‘softwareupdate --install Xcode’ and I got this message: ‘Xcode: No such update
No updates are available.’

So my question is. Do I have xcode installed in my computer and if so, how do I know it? Should I keep going and install the rest of the programs? Or, I’ve seen comments that advise to run ‘sudo xcode-select -s /Library/Developer/CommandLineTools’ to fix my issue but TOP specifies not to use sudo.

Thank you all in advance!


#2

If it says it’s already installed then it probably is.

If you open up the mac app store and look in the update section it will tell you if there is an update for xcode available otherwise assume it’s up to date.


#3

According to the mac app store is not even installed, should i just install it from there and keep going?

Thank you again!