Ruby installation error


#1

Hi All,

I am having trouble bundling in 3.5.2 of the 101 course.

The error message i receive is this:

An error occurred while installing pg (1.1.4), and Bundler cannot
continue.
Make sure that gem install pg -v '1.1.4' --source 'https://rubygems.org/'
succeeds before bundling.

In Gemfile:
pg

does this mean I don’t have the correct ruby installed?

Any help would be greatly appriciated

Thanks,
Mackenzy


#2

It means you are trying to install the postgres gem when the postgres database isn’t installed. The pg gem should be in the production group in your gemfile and you should be trying to install it with bundle install --without-production