Rbenv: no such command `install'


#1

Hello! I am trying to install Ruby (step 3.3 on OSX Mojave system). When I type rbenv install 2.6.3 --verbose, I get this message:

rbenv: no such command `install’

I’ve tried uninstalling and re-installing rbenv, and I also did a “brew update” and “brew upgrade ruby-build”. All of those things updated and upgraded just fine, but I still get the no such command `install’ , even if I re-start terminal or re-start the computer.

Any help is greatly appreciated. I’ve googled and googled and also tried Discord, but alas, nothing has worked so far.

Thanks!


#2

here are some other solution. Try to install ruby-build with apt-get.


#3

Thanks! I spent a lot of time on that page yesterday. There are a lot of different answers to that question, and I wasn’t sure where to begin. I first tried this (under #238):

On Mac OS X you can install it through homebrew:

brew install ruby-build

That didn’t work, and I wasn’t sure about what exactly the others did. Soooo, today I tried this link also from the same answer, first option, because I figured might as well, who knows. (It was scary because I didn’t know if that’s what would work for my set-up.) This finally solved it!!! YAAAAAYYYY!!!

git clone https://github.com/rbenv/ruby-build.git “$(rbenv root)”/plugins/ruby-build

Hooray! Thanks for suggesting it again. It spurred me to be more adventurous! :grin:


#4

Thank you for this - helped me get set up today!