Rails: Precompiling assets failed Error


#1

I’ve been trying to fix it for 3 days now and lovely, tons more experienced people on Discord took a shot at it.
Here is my error:
https://pastebin.com/gvL5eTeA

And here is my public repo:

We tried everything, I even started a new Heroku project and a new Rails app just in case. But no dice.

It just feels like it’s a waste of time since I’m not learning anything so I’ll skip it for now.


#2

Run bundle exec rails webpacker:install in the rails project folder in your terminal.


#3

Gives me the same error, and it overwrote some files


#4

Try yarn check --integrity and let me know the output


#5
yarn check v1.19.2
success Folder in sync.
Done in 0.09s.

#6

What version of rails are you using?


#7

Rails 6.0.1


#8

The weird thing is someone copied my repo and was able to push to Heroku no problem…

I even started a new rails app and a new Heroku app too.


#9

Should I just not worry about it since it’s the beginning?


#10

If someone else was able to push maybe you should reinstall the heroku cli


#11

Okay, I uninstalled it and downloaded it using snap.
Giving me the same error


#12

It’s really hard to say without knowing how your system is set up and what you’ve actually installed. I say move on for now and see if you still encounter any issues.


#13

Thanks. I know you have a shit ton of experience so it helps to know I’m not making a bad decision by moving on.

If I run into these issues with my next rails app, then I will certainly investigate it.