Problem with eventmachine gem while bundling mini-twitter app from tutorials

Right as I was starting to make my way through the Rails mini-twitter tutorial videos, I ran across this problem while attempting to bundle my app: right after the tutorial loads up a couple of gems; better errors and a couple more, I ran into this error and have no idea how to solve it.

ruby version is:
ruby 2.6.3p62 (2019-04-16 revision 67580) [x86_64-linux]

Building native extensions. This could take a while...
ERROR:  Error installing eventmachine:
	ERROR: Failed to build gem native extension.

    current directory: /home/lou/.rbenv/versions/2.6.3/lib/ruby/gems/2.6.0/gems/eventmachine-1.2.7/ext
/home/lou/.rbenv/versions/2.6.3/bin/ruby -I /home/lou/.rbenv/versions/2.6.3/lib/ruby/2.6.0 -r ./siteconf20200715-4963-jg74w4.rb extconf.rb
checking for -lcrypto... yes
checking for -lssl... yes
checking for openssl/ssl.h... yes
checking for openssl/err.h... yes
checking for rb_trap_immediate in ruby.h,rubysig.h... no
checking for rb_thread_blocking_region()... no
checking for rb_thread_call_without_gvl() in ruby/thread.h... yes
checking for rb_thread_fd_select()... yes
checking for rb_fdset_t in ruby/intern.h... yes
checking for rb_wait_for_single_fd()... yes
checking for rb_enable_interrupt()... no
checking for rb_time_new()... yes
checking for inotify_init() in sys/inotify.h... yes
checking for writev() in sys/uio.h... yes
checking for pipe2() in unistd.h... yes
checking for accept4() in sys/socket.h... yes
checking for SOCK_CLOEXEC in sys/socket.h... yes
checking for sys/event.h... no
checking for epoll_create() in sys/epoll.h... yes
checking for clock_gettime()... yes
checking for CLOCK_MONOTONIC_RAW in time.h... yes
checking for CLOCK_MONOTONIC in time.h... yes
CXXFLAGS=$(cxxflags)
creating Makefile

current directory: /home/lou/.rbenv/versions/2.6.3/lib/ruby/gems/2.6.0/gems/eventmachine-1.2.7/ext
make "DESTDIR=" clean

current directory: /home/lou/.rbenv/versions/2.6.3/lib/ruby/gems/2.6.0/gems/eventmachine-1.2.7/ext
make "DESTDIR="
compiling binder.cpp
make: g++: Command not found
Makefile:235: recipe for target 'binder.o' failed
make: *** [binder.o] Error 127

make failed, exit code 2

Gem files will remain installed in /home/lou/.rbenv/versions/2.6.3/lib/ruby/gems/2.6.0/gems/eventmachine-1.2.7 for inspection.
Results logged to /home/lou/.rbenv/versions/2.6.3/lib/ruby/gems/2.6.0/extensions/x86_64-linux/2.6.0-static/eventmachine-1.2.7/gem_make.out

Don’t know what other info would be relevant to provide; thanks in advance!