Problem in step 3.7: Push to Heroku


#1

Hi, to all, first approaching to programming, on this step the CLI find this error after the command

git push heroku master

The error in question is the following:

remote:  !
remote:  !     There was an error parsing your Gemfile, we cannot continue
remote:  !     
remote:  !     [!] There was an error parsing `Gemfile`: syntax error, unexpected keyword_end, expecting end-of-input. Bundler cannot continue.
remote:  !     
remote:  !     #  from /tmp/build_4cc0589b4136dbdbdbe16e62ecd03f24/Gemfile:10
remote:  !     #  -------------------------------------------
remote:  !     #   gem 'sqlite3'
remote:  !     >  end
remote:  !     #
remote:  !     #  -------------------------------------------
remote:  !
remote:  !     Push rejected, failed to compile Ruby app.

#2

As it says, you have a syntax error in your Gemfile. The is an end word in the wrong place. Have a look and see if you can spot it.


#3

**Just wanted to say that I figured it out and have moved on. Not sure what I did…haha…but it worked.

didn’t see a resolution for this and I am having a similar issue, as well. Here is a copy of my error:

remote: Tasks: TOP => environment
remote: (See full trace by running task with --trace)
remote:
remote: !
remote: ! Precompiling assets failed.
remote: !
remote: ! Push rejected, failed to compile Ruby app.
remote:
remote: ! Push failed
remote: Verifying deploy…
remote:
remote: ! Push rejected to warm-dawn-16425.
remote:
RAW Paste Data
remote: Tasks: TOP => environment
remote: (See full trace by running task with --trace)
remote:
remote: !
remote: ! Precompiling assets failed.
remote: !
remote: ! Push rejected, failed to compile Ruby app.
remote:
remote: ! Push failed
remote: Verifying deploy…
remote:
remote: ! Push rejected to warm-dawn-16425.
remote:

I wasn’t sure how much to copy so if you need additional info, please let me know. I’ve been trying to Google these errors and I’m just stuck at this point.

Thanks in advance for any guidance.strong text


#4

Hey @txjenn

Is there more to that error?


#5

I wasn’t sure exactly what to copy and paste but I figured out the problem. Well, I’m not really sure what I did but it finally worked and I was able to move on.

Thanks for asking, though. :slight_smile: