Need assistance creating dev ecosystem/ Step 4.5.1. First Rails Application


#1

Greetings!

I am new to TOP, and am currently working my way through Web Dev 101 and am working through the instructions to establish my dev ecosystem on my Mac OS.

I am stuck at Step 4.5.1. Specifically, I AM LOGGING (. code) INTO MY TERMINAL (as noted in the instructions below) AND ITS RETURNING --COMMAND NOT FOUND. I also went back and completed steps 4.2 & 4.3. successfully. At this point, I am not sure what the error is. Can anyone provide clarification?

INSTRUCTIONS BELOW:
"Step 4.5.1: Configure the Gemfile

To deploy a Rails application, we need to change some settings.

First, we need to open the Gemfile and edit it.

In your terminal, type ls and verify that you see Gemfile in the output. If you don’t see it, navigate to the directory you created in Steps 4.2 and 4.3.

Then, we’ll use VSCode to modify the Gemfile. Open your app in VSCode by typing code . (NOTE: The period at the end is important!) (WSL users: If you type code . and you see system32 in the top left, you have created your application outside of the Projects directory we created earlier.)

When VSCode opens, you should see a list of files on the left side of the screen. . . "

Thoughts? Many thanks!


#2

https://www.theodinproject.com/courses/web-development-101/lessons/text-editors

MacOS can do this, too, but you need to set it up. After installing VSCode, launch it any way you’re comfortable with. Once it’s running, open the Command palette with CMD + Shift + P. In the little dialog that appears, type shell command. One of the choices that appears will be Shell Command: Install ‘code’ command in PATH. Select that option, and restart the terminal if you have it open.

You might have missed this step.


#3

Thank you so much for the information (CANNOT OVERSTATE THIS!!).

I was able to proceed and open VS Code through the terminal, BUT WAS NOT ABLE TO LOCATE THE GEMFILE on the left sidebar, as noted in the next step:

""When VSCode opens, you should see a list of files on the left side of the screen. Click on Gemfile to open it in the editor. Then, delete the line that says,

gem ‘sqlite3’ , ‘~> 1.3.13’""

I uploaded an image of what I see on my screen. There is a file called gem, which when clicked, does NOT open in editor, which the above instructions states it should do. I have no clue as to why. Any thoughts as to why? Or how I can locate the file?

Many thanks again !

Gemfile


#4

You need to be in your rails app directory in the terminal when you type code .

Looks like you are in your home directory there.


#5

Thanks! You helped me get past my ‘little mistake’