My_first_web_app not working (webpacker error)


#1

I was doing web tutorial 101 and when trying to create my rails app http://localhost:3000/cars was just not working when I opened it even though I had no errors. I deleted the entire my_first_rails_app folder and did the steps again and now I am getting the error

Webpacker configuration file not found /home/adam/blog/config/webpacker.yml. Please run rails
webpacker:install Error: No such file or directory @ rb_sysopen - /home/adam/blog/config/webpacker.yml
(RuntimeError)

Whenever I try bundle exec rails webpacker:install or rails webpacker:install I get the error

rails aborted!
ArgumentError: Malformed version number string 0.32+git
bin/rails:4:in `<main>'
Tasks: TOP => webpacker:install => webpacker:check_yarn
(See full trace by running task with --trace)

If it helps I am on Ubuntu 19.10 and using Rails 6.0.2.1 and ruby 2.6


#2

If you are using rails 6 then you need to have yarn and webpacker installed. That is why for now we are recommending rails 5.2.3. You can install that with gem install rails -v 5.2.3 and then you can run rails _5.2.3_ new my_first_rails_project or whatever it’s supposed to be called. You might need to delete the old rails project folder first.