$ [main 09:50:57] update#setState idle bash: cannot set terminal process group (-1): Inappropriate ioctl for device bash: no job control in this shell


#1

$ [main 09:50:57] update#setState idle
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

Can anyone explain what the above means in my terminal, it appears after i CD and xdg-open my index.html file for web dev 101 google-homepage. Thanks


#2

What OS are you using?


#3

ubuntu


#4

Does index.html open in a browser?


#5

Hi sorry for delay in replying. The only way index.html opens in a browser is by using the click and open with different app option, from the terminal, index.html can only open with the default app which is vscode.


#6

For anyone else having the above problem of opening specific files from terminal in Ubuntu, i have found that you must type the application that you want to open the file with, eg at the prompt $ type the app you want the file to open with, if you want to open it with firefox, the following does that : $ firefox “filename here” this will now open the file with firefox rather than the default application. Hope this helps