Issues with the installation phase of the web-dev 101 course using Debian 9


#1

Hello, I am using a Debian 9 Virtual machine on VMWare as my OS for the web-dev 101 part of the Odin Project and I have encoutered a few stalling issues during the tools installation phase.

The first time around, I removed the GUI during installation and successfully ran VSCode. However, when time came to install ruby-build, the command to create the plugins directory ketp failing, with Linux telling me it couldn’t find the rbenv command, which I find to be a rather strange response to that particular input. I tried restarting the machine, only to discover three things:

  1. One of the packages I isntalled in the meantime had brought the GUI back without warning;
  2. A critical package was suddenly missing (I don’t remember what it was called);
    3.The machine was apparently broken beyond functioning and wouldn’t do anything anymore.

So I installed a new machine all over again, this time around with the GUI. For whatever reason, I had to use a different method to give my user sudo privileges, as the one I had used the first time, despite seemingly working fine, seemed to do absolutely nothing. Then my first attempt at opening a new folder with VSCode generated an infinite loop of “the window has crashed” errors until I resigned myself to closing the software. As it turns out, neither VSCode nor Sublime Text will actually run, with Linux saying that “cloning” (cloning just to start a software ? What ?) failed because it cannot allocate memory.

I tried looking up both of these incidents on Google, but the potential solutions I found all alluded to various strains of Linux tools which I have no idea what any of them do or why they exist. I’d rather not recklessly interact with any of them only to generate more headaches for myself later on.

So what’s going on here ? I mean, I’ve always used debian for app deployment in my as yet very short professional carreer. Is using it for the Odin Project too ambitious ? Should I move to a more straightforward Linux distribution ? Mind you, not to be rude to anyone wanting to help, but please do not reflexively jump to this as being the problem-generating factor. Either you actually know that trying to use Debian is what is causing me these hardships and therefore know why that is, or you don’t.

Or, alternatively, is there something else I’m just not seeing ?


#2

This post was flagged by the community and is temporarily hidden.