Issue with First Rails Project


#1

Hi All,

So I’m just starting out on the first Rails application project and I get an error when loading http://localhost:3000/cars and in my terminal (below error message):

Webpacker configuration file not found /home/amzer/Projects/odin_on_rails/my_first_rails_app/config/webpacker.yml. Please run rails webpacker:install Error: No such file or directory @ rb_sysopen - /home/amzer/Projects/odin_on_rails/my_first_rails_app/config/webpacker.yml (RuntimeError)

The course does say that this is all to make sure that everything is running properly - which it clearly isn’t going by these messages. When I scroll up in my Terminal I come across the below:

Yarn not installed. Please download and install Yarn from https://yarnpkg.com/lang/en/docs/install/

As the course hasn’t mentioned anything about installing Yarn I’m hesitant to do so but I’m also at a bit of a loss as to where I’ve messed up - especially as the part of the project is basically copy/pasting.

If any one can point me the right direction that would be great.

Cheers


#2

try to install the yarn package
with OS are you using?


#3

I’m using a Linux VM.

I am contemplating installing the yarn package but TOP course says not to use any sudo or install anything with apt, both of which are needed to install yarn from the link that is appearing the terminal - https://yarnpkg.com/lang/en/docs/install/#debian-stable

any other suggestions or is it possible that I messed up somewhere while copy/pasting and not everything has been installed correctly?


#4

I went ahead and installed yarn but I’m still getting the same error message about the Webpacker configuration file not being found…


#5

Linux VM but wich distribution? arch, debian?

there are different instructions to install for each type of distribution but, if it install as you say is a little weird


#6

I just went through the same issue.
In your “my_first_rails_app” directory, or however you named it, you’ll want to run:

$ rails webpacker:install

This should install the webpacker since you already have yarn installed. After the webpacker has finished installing, you should be able to run the “rails server” command and open the cars application page.

I hope this works for you!


#7

It actually all started to come together and work after Yarn was installed but apparently there is a bigger issue at the moment when you try to push the app to Heroku. A lot of people seem to be having an issue and have been discussing it in TOP Discord. The fix seems to be to downgrade rails from 6.0 to 5.2.3. However, I’m now having issues deleting my app and starting all over again. The life of a noob is one of constant roadblocks and confusion :slight_smile:


#8

@ALKessler - rails webpacker:install worked for me. Well, at least the server started and I can move past this error. Thanks for helping me out!