Incompatible Library Version on First Rails Application


#1

I haven’t run into much trouble so far. Doing the My First Rails App, when I generate the scaffold, I get the following code:

https://pastebin.com/9JenLDqT

I’m new enough that I really don’t know what to do about this to fix the problem.

Any help would be appreciated.


#2

Hi @jayqueue2

Are you following the latest install instructions? If so they would have asked you to install rbenv to manage your Ruby versions but I can see from your path there you also have rvm installed.

rvm and rbenv can’t both be installed. Our current recommendation is rbenv so you can type rvm implode into your terminal to uninstall it. If you aren’t using rbenv then you don’t need to uninstall rvm and it’s a different issue. Let me know.


#3

I’ll look into this. RVM was installed by a friend of mine because I started a web project using developers before I knew anything about programming. Are there any dangers with swapping between rvm and rbenv?


#4

No, you just can’t have both installed.