I need Help Installing Ruby


#1

I keep trying to update in the terminal like I’m told but, I keep getting an error. E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
Any ideas on what I can do?


#2

Try to solution posted here: https://www.linuxuprising.com/2018/07/how-to-fix-could-not-get-lock.html?m=1

Essentially what’s happening is something else Is probably using var/lib/dpkg/lock. Do you have another terminal open that is updating something? Or did you start updating programs through the GUI based package manager/software updater These might be already tasking the resource.


#3

I actually did and I did not realize it. I was able to get past that stage and now I’m trying to run code . to bring up the editor for Gemfile and it keeps telling me that command code not found? I know I am in the directory I am supposed to be in, but I have no idea what is wrong now.


#4

Are you using a VM? Did you install VS code inside the VM (the linux version)


#5

I am an idiot. I did not install the correct vs code for linux. Anyway, I finally had that all up and running and now I am getting remote: !
remote: ! Precompiling assets failed.
remote: !
remote: ! Push rejected, failed to compile Ruby app.
remote:
remote: ! Push failed
remote: Verifying deploy…
remote:
remote: ! Push rejected to intense-spire-20284.
remote:
To https://git.heroku.com/intense-spire-20284.git
! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to ‘https://git.heroku.com/intense-spire-20284.git
whenever I try and push heroku master. I went back to look at routes.rb and it is set up correct.