Http://localhost:3000/cars Doesn't work

Everything up to this point seems to have worked correctly.

I could be trying to open this incorrectly. I don’t have a web browser installed on my virtual machine, so I tried to open it on my host, which doesn’t seem right. Do I need to install a web browser on my virtual machine or is there another way I should be opening this?

It didn’t work for me either and I am using Firefox on the VM.

1 Like

You can’t use a host browser when running code in a VM. Any linux distro will have a built in browser you can use.

I’m using Ubuntu and I can’t open the browser. It keeps telling the connection isn’t secure.

What connection? localhost?

I also had an issue getting this to run but resolved it so sharing here…In the VM, I right clicked on the desktop and selected Create URL link. I pasted the localhost:3000 link in the URL field. Clicked Create. When I launched it from my desktop, it launches Firefox and the Cars application is running in the browser.

1 Like

Hey, did you figure it out? did it work for you? I’m facing the same issue. i tried searching online for any solution and nothing.

Can you provide some more details about the issue @iam-hr-523?

I am facing the same issue, I have tried to create the URL lick on desktop, but had no luck?

Could it have something to do with chromedriver-helper being depreciated? Or Ruby sass reaching the end of life? I have tried to search for fixes for both these issues but have had zero luck finding out how to rectify these. please help?

@3dayweekend

Type heroku logs into the terminal when in the rails project folder. That should give you an indiciation of any potential error.

Thanks for your reply mate, I redid a bunch of the steps and it worked the second time. I think seeing the warnings about the old sass and chromedriver threw me.:call_me_hand:

Hey folks,

Go back to https://www.theodinproject.com/courses/web-development-101/lessons/your-first-rails-application?ref=lnav and re-read the instructions. I missed cd my_first_rails_project. after I fixed that everything worked okay.

I’m having issues with opening http://localhost:3000/cars… I have tried redoing the steps on https://www.theodinproject.com/courses/web-developmebt-101/lessons/your-first-rails-application?ref=lnav but nothing seems to work. I typed heroku logs into my terminal like CouchofTomato suggested and it said that I am missing the required flag: -a, --app. What do I do?

@anna-christian77 Can I see a screenshot of your terminal please?

It says it can’t find a javascript runtime which means you don’t have nodejs installed.

Try installing it from here https://nodejs.org/en/download/

ok so after I install nodejs, what do I do? Do I redo all the steps or just try reloading localhost3000?

I tried redoing the steps in the hopes that installing nodejs would solve the problem, but when I got to the step for creating the application, the terminal said I had another error. can someone help me understand what’s going on and maybe help me with a solution?

That happened because when you created a rails app it already existed from the first time you created it so those warnings are telling you that if it creates those new files will overwrite the previous ones.

I would just delete the my_first_rails_app directory and then start again from the rails new command to create the app again.