Homebrew install requesting password help! [SOLVED]


#1

hello friends!
I am very new so I’m sorry if this seems remedial.
I am working through Web Development 101 - Installing Ruby (for MacOS) and I have reached step 1.2, installing Homebrew. I have copied and pasted the command:

/usr/bin/ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”

and upon hitting enter it brings me the following message:

This script requires the user paige to be an Administrator.

I wasn’t sure what to do so I tried entering my password and it just populates “event not found”.
I’m not really sure what to do from here, if I should be entering a password or something else? I’ve scoured forums for TOP and Homebrew and I haven’t found anything related, which leads me to believe its a me/my OS issue.
Anyway I’m hoping for a nudge in the right direction - I’ve been at this for a few hours :frowning:
Thank you for helping a newb!


#2

A screenshot would really help in finding a solution.
Anyways, have you tried running the command as an administrator? this can be done with

sudo "the command"

It will then ask for your password which you should enter. Or try entering

su

in the terminal, it will ask for a password, enter it then run your command.


#3

Hello!
Thank you for your quick response! Below is a screenshot of the initial command and the response I get.

Let me know what you think and I will give your suggestions a shot! Thanks again!


#4

Behold your suggestion has worked! Thank you so much, this is solved


#5

Delighted to help