Hit a snag on Step 4.7 Your First Rails Application


#21

You’re going to need to open your .bash_profile in your text editor and add the following line to it

eval “$(rbenv init -)”

Add it at the end. Save and close all terminals then open a new terminal and type ruby -v and see what happens.


#22

ruby 2.5.3p105 (2018-10-18 revision 65156) [x86_64-darwin18]


#23

Looks good to me.


#24

I was finally able to deploy the app after playing with it and changing code. I turns out that it wasn’t updated in my gemfile and gemfile.lock that I wanted to use Ruby 2.5.3 instead of the older version. I also changed it to Ruby 2.5.3 in .ruby-version, applied to changes and redeployed and this actually worked this time. Took 3 days to finish just that assignment alone, now I can try to finish the rest of it.


#25

Getting set up can be difficult but that’s part of programming unfortunately. Learning to debug is such a useful skill.

Keep at it and things will get easier.


#26

Ran into the same problem.
When I do cat ~/.bash_profile

# Setting PATH for Python 3.6
# The original version is saved in .bash_profile.pysave
PATH="/Library/Frameworks/Python.framework/Versions/3.6/bin:${PATH}" export PATH

# Setting PATH for Python 3.7
# The original version is saved in .bash_profile.pysave PATH="/Library/Frameworks/Python.framework/Versions/3.7/bin:${PATH}"
export PATH
eval "$(rbenv init -)"


#27

for echo $PATH I get:
/Users/Dmitrij/.rbenv/shims:/Library/Frameworks/Python.framework/Versions/3.7/bin:/Library/Frameworks/Python.framework/Versions/3.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin


#28

What OS are you using?