Help! You don't have write permissions for the /Library/Ruby/Gems/2.6.0 directory


#1

I’m trying to install rails and I keep getting this error. “You don’t have write permissions for the /Library/Ruby/Gems/2.6.0 directory”.

I followed everything step by step and now I’m not sure what to do. please help!


#2

Hey @mistabelize

It looks like Ruby has installed at the system rather than the user level. Can you share the output of echo $PATH in your terminal please?


#3

/Users/FDSEarl/.rbenv/shims:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin


#4

Can you also confirm the output of which ruby please.