Git Basics - push origin master not working


#1

Hi there,

I’m stuck on the Web Development 101: Practicing Git Basics. Every step so far worked with no problem, but when I try to push my work to GitHub with the command git push origin master, I get the following error message:

ERROR: The key you are authenticating with has been marked as read only.
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

I’ve seen the same question asked before, where the user was told to try the command ssh -T git@github.com (I didn’t quite understand why, though). I tried the same, upon which I got:

Hi Heaver-H/name! You’ve successfully authenticated, but GitHub does not provide shell access.

Now the repository is called git_test, this message refers to /name. I don’t know if that is of any importance, though. Unfortunately, in the other topic the issue was resolved by the user without sufficient explanation, so I’m opening up a new one here.

Any help would be appreciated, I’ve been stuck on this for quite some time now!


#2

are you on a mac?


#3

do you have a private repo?
idk but check this link