Git Basics Project - SSL Certification Problem? ***SOLVED***


#1

Having trouble doing the Git Clone portion of the “Git Basics” project in Web Development 101. I completed steps 1-4 without issue. I originally did the git_test without the README and had the SSL Cert issue. So I deleted it and created a new repository. I made sure I included a “README” as GitHub recommended, for cloning purposes. Doesn’t seem to have helped.

I updated my git version this morning before starting the project. I rebooted my computer. I’m not sure where I’m going wrong, but this is the error information I receive when I try “git clone.”

C:\Sites>git clone https://github.com/Amber-Pittman/git_test
Cloning into 'git_test'...
fatal: unable to access 'https://github.com/Amber-Pittman/git_test/': SSL certificate problem: self signed certificate in certificate chain

C:\Sites>git --version
git version 2.18.0.windows.1

How is it an SSL problem? Is it a Github website issue? Or am I supposed to change something within my GitHub settings? Or is it something on my desktop Git?

Should I still be in Railsbridge instead of just Sites?


#2

hi @Amber-Pittman ,
try this git -c http.sslVerify=false clone https://example.com/path/to/git


#3

@AREEBAISHTIAQ Thank you very much! Worked like a charm! :sunglasses:

Have a great week and happy coding!

Amber