Git add -A freezing / stuck


#1

Hi all.

I am trying to add all files and folders from my working directory to git.

I’ve tried using the command git add -a / git add --A / git add --all / git add * and git add .

When I click enter, it freezes just has the blinking text line and stays froze, I’ve waited ten or 15 minutes with no joy so have to CTRL+ALT+C to stop the command.

Does anyone know why this may be happening, am I doing something wrong?

My files are stored on my local machine but in a cloud storage folder (pcloud) so I’ve done git init in the pwd which worked fine and then tried git add with all of the variations above but none of them appear to work.

Any help, support or advice would be greatly appreciated TIA


#2

Hi there!

Getting started with Git was a little difficult for me to. I don’t know what exactly is happening, but maybe we can diagnose the problem together!

On the command line type this:

git status

and then tell me what you see.

I’m expecting something like:

On branch master
nothing to commit, working tree clean

or maybe

On branch master
Changes not staged for commit: 

#a bunch of lines of some other stuff

let me know and maybe we can solve this together!


#3

Hey thanks for offering to help, it’s greatly appreciated.

I’ve checked git status and this is the message I get

It says on branch master, no commits yet, Untracked files: (use “git add …” to include in what will be committed) followed by a list of my folders in pwd all in red then this line:

nothing added to commit but untracked files present (use “git add” to track)

I have tried the git add as suggested by this command but then it just does what I said in my original post. Just stays with a text blinker after I click enter on git add command.


#4

ok, so then you attempt to add the files with:

git add .

and you’re only left with a blinking cursor, correct?

Edit:

From a quick Google search, I’ve found a couple of possible solutions:

  • Try restarting your machine
  • When you get to the point of only having the blinking cursor, hit enter (or return) again
  • Take a look at what files you’re attempting to commit; Are there any files you think shouldn’t be there?

My last suggestion comes from the idea that certain file types (binary files) take a long time to add. Which comes from this article (but if you’re just starting out, don’t bother with the StackOverflow article…it’ll only confuse you).

Edit 2:

Looking at your original post, you said you’re trying to add all files and folders from your working directory. What do you see in the command line when you type:

pwd

#5

Ok, so I’ve been digging around and posted this in multiple areas to try and get as quick a response/fix as possible.

Someone on Reddit told me that using cloud storage with git is very inefficient and unnecessary, when I moved the pwd outside of my local/cloud storage folder it fixed the issue and I was able to git add . just fine.

The issue I have now is that when doing a git add . and then git status while it’s added and tracked the VAST majority of my files and folders, it’s got a few showing in red mainly .png files and a few .php I could try and add these manually but there’s a good 20+ files which would be a little time consuming, not sure why git add . and git add --all isn’t letting them be tracked/added like all my other files and folders.


#6

Looks like you got past your original issue, so I think you’re all good.

Keep learning!


#7

Thank you, even fixed my additional hurdle as well I didn’t notice there was a background window still open downloading some of my files so that’s why some were missing.

Thank you for your help, it was greatly appreciated!