First rails application, stuck at heroku, went "home" once


#1

Oke so perhaps I did something stupid. I should’ve done all of this exactly the way the Odin Project told to. But at step 3 I decided I probably should have to move into home again and did everything from there. Is that correct?

I ran into trouble when I had to do “git remote” . And I got an error message saying “fatal: not a git repository (or any of the parent directories): .git”.

Then I went back into my_first_rails_app and did “git remote” and it said “origin”. Not “heroku”.

So that’s possibly dumb of me but I wonder how and where and how far I’ve gone wrong by this point. I haven’t touched it anymore since.


#2

i had issues with that as well. i don’t think i encountered the same thing, but i just basically started that section over and made sure i was following the lesson verbatim, and it worked perfectly. i still don’t know what i did wrong


#3

The thing I don’t like about Linux is if I start over now in a different approach, I’m stuck with a nagging feel like the first time around has changed something in the system in a weird way. I don’t know how to reverse it. Because everything is done in the command line I’m not sure anymore what it did do and didn’t do. Can I just ignore it or do I have to clean it up in some way. That’s my limited knowledge of computers, probably. But it’s the way I think then.

Does anybody have a tip about what mindset to have on this and these kind of trouble? Because I get it all the time with linux. That I somehow did something and I don’t know how to reverse it.


#4

i was apprehensive about it too and thought about ignoring mine too so i can keep going, but saw it as a necessary step to finish so i didn’t leave any part of the course undone.