Errors with first Ruby on Rails Application


#1

I am trying to complete Step 2.4 for my first Rails application. When I click the link http://localhost:3000/cars I get an error in my browser No route matches [GET] “/cars”. Can anyone help me understand what is wrong? This is after I have typed rails server into Terminal.

The code output is :
Started GET “/cars” for 127.0.0.1 at 2019-03-03 17:36:26 -0800

ActionController::RoutingError (No route matches [GET] “/cars”):

actionpack (5.2.2) lib/action_dispatch/middleware/debug_exceptions.rb:65:in call' web-console (3.7.0) lib/web_console/middleware.rb:135:incall_app’
web-console (3.7.0) lib/web_console/middleware.rb:30:in block in call' web-console (3.7.0) lib/web_console/middleware.rb:20:incatch’
web-console (3.7.0) lib/web_console/middleware.rb:20:in call' actionpack (5.2.2) lib/action_dispatch/middleware/show_exceptions.rb:33:incall’
railties (5.2.2) lib/rails/rack/logger.rb:38:in call_app' railties (5.2.2) lib/rails/rack/logger.rb:26:inblock in call’
activesupport (5.2.2) lib/active_support/tagged_logging.rb:71:in block in tagged' activesupport (5.2.2) lib/active_support/tagged_logging.rb:28:intagged’
activesupport (5.2.2) lib/active_support/tagged_logging.rb:71:in tagged' railties (5.2.2) lib/rails/rack/logger.rb:26:incall’
sprockets-rails (3.2.1) lib/sprockets/rails/quiet_assets.rb:13:in call' actionpack (5.2.2) lib/action_dispatch/middleware/remote_ip.rb:81:incall’
actionpack (5.2.2) lib/action_dispatch/middleware/request_id.rb:27:in call' rack (2.0.6) lib/rack/method_override.rb:22:incall’
rack (2.0.6) lib/rack/runtime.rb:22:in call' activesupport (5.2.2) lib/active_support/cache/strategy/local_cache_middleware.rb:29:incall’
actionpack (5.2.2) lib/action_dispatch/middleware/executor.rb:14:in call' actionpack (5.2.2) lib/action_dispatch/middleware/static.rb:127:incall’
rack (2.0.6) lib/rack/sendfile.rb:111:in call' railties (5.2.2) lib/rails/engine.rb:524:incall’
puma (3.12.0) lib/puma/configuration.rb:225:in call' puma (3.12.0) lib/puma/server.rb:658:inhandle_request’
puma (3.12.0) lib/puma/server.rb:472:in process_client' puma (3.12.0) lib/puma/server.rb:332:inblock in run’
puma (3.12.0) lib/puma/thread_pool.rb:133:in `block in spawn_thread’


#2

Solved. Regenerated templates.


#3

I’m having the same problem. Do you mind telling me what you did? Thanks!


#4

I just typed in

rails generate scaffold car make:string model:string year:integer

And then did

rails db:migrate

Then this worked after the rails server was running again


#5

I must have a different error somewhere. Back to start, I guess.