Error on Step 3.4 of Web Dev 101


#1

Hi all, starting on the Web Dev 101 course, and I’m running into an error on step 3.4 of the first Ruby app. When I type in $ heroku create, I get error messages, and the followup $ git remote also does not work:

jcbluemel@jcbluemel-VirtualBox:~$ heroku create
(node:4474) [EACCES] Error Plugin: heroku: EACCES: permission denied, open ‘/home/jcbluemel/.cache/heroku/version’
module: @oclif/config@1.13.2
task: runHook init
plugin: heroku
root: /usr/local/lib/heroku
See more details with DEBUG=*
(node:4474) [EACCES] Error Plugin: heroku: EACCES: permission denied, mkdir ‘/home/jcbluemel/.cache/heroku’
module: @oclif/config@1.13.2
task: runHook init
plugin: heroku
root: /usr/local/lib/heroku
See more details with DEBUG=*
Creating app… done, ⬢ agile-shelf-05724
https://agile-shelf-05724.herokuapp.com/ | https://git.heroku.com/agile-shelf-05724.git
(node:4474) [EACCES] Error Plugin: heroku: EACCES: permission denied, unlink ‘/home/jcbluemel/.cache/heroku/autocomplete/completions/app’
module: @oclif/config@1.13.2
task: runHook recache
plugin: heroku
root: /usr/local/lib/heroku
See more details with DEBUG=*
jcbluemel@jcbluemel-VirtualBox:~$ git remote
fatal: not a git repository (or any of the parent directories): .git


#2

It appears your project isn’t configured with git. Do you have the project on GitHub?
If so, then run the following:
git init
git add .
git commit -m "first commit"
git remote add origin https://github.com/<your_username>/<your_project>.git
git push -u origin master

If not, then you’ll need to create the repository on github, then run the above in your terminal.


#3

Thank you for the response. I have the project on GitHub, and followed your instructions, but no dice.

I went back to the beginnning of setting up Heroku, where it asks me to use a curl command to set up. I’m noticing I am getting the permission denied dialog here as well, but I have no frame of reference for if it should be saying that or why. I figure it might be a related issue?

jcbluemel@jcbluemel-VirtualBox:~/odin_on_rails/my_first_rails_app$ curl https://cli-assets.heroku.com/install.sh | sh
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1892 100 1892 0 0 2539 0 --:–:-- --:–:-- --:–:-- 2536
This script requires superuser access.
You will be prompted for your password by sudo.
[sudo] password for jcbluemel:
Installing CLI from https://cli-assets.heroku.com/heroku-linux-x64.tar.xz
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 17.0M 100 17.0M 0 0 9008k 0 0:00:01 0:00:01 --:–:-- 9003k
v12.13.0
heroku installed to /usr/local/bin/heroku
(node:4780) [EACCES] Error Plugin: heroku: EACCES: permission denied, open ‘/home/jcbluemel/.cache/heroku/version’
module: @oclif/config@1.13.2
task: runHook init
plugin: heroku
root: /usr/local/lib/heroku
See more details with DEBUG=*
(node:4780) [EACCES] Error Plugin: heroku: EACCES: permission denied, mkdir ‘/home/jcbluemel/.cache/heroku’
module: @oclif/config@1.13.2
task: runHook init
plugin: heroku
root: /usr/local/lib/heroku
See more details with DEBUG=*
heroku/7.35.0 linux-x64 node-v12.13.0


#4

Can you try running the install with sudo curl https://cli-assets.heroku.com/install.sh | sh. Also, don’t run the installation in your project folder. Type cd to go back to your home directory (jcbluemel@jcbluemel-VirtualBox) and try the installation there.

Another thing you might want to try is deleting the .cache folder. Something might have configured improperly on the first install. These are just guesses, wish I could be more helpful!


#5

I appreciate the assistance! Neither worked, but hopefully I can figure it out!