Eror sqlite3


#1

For the past hours i couldnt pass sqlite3 error
I changed the sqlite3 to gem sqlite3
/home/mayism/.rbenv/versions/2.6.0/lib/ruby/gems/2.6.0/gems/railties-5.2.2/lib/rails/app_loader.rb:53: warning: Insecure world writable dir /home/mayism/.rbenv/versions in PATH, mode 040777
/home/mayism/.rbenv/versions/2.6.0/lib/ruby/2.6.0/bundler/rubygems_integration.rb:408:in `block (2 levels) in replace_gem’: Error loading the’sqlite3’ , ‘~> 1.3.13’ Active Record adapter. Missing a gem it depends on? can’t activate sqlite3 (~> 1.3.6), already activated sqlite3-1.4.0. Make sure all dependencies are added to Gemfile. (LoadError)
then I saved it
but nothing had changed , the output keeps give me the same error


#2

This looks like the problem (and solution) discussed here.

Basically; try changing the line in the Gemfile gem ‘sqlite3’ to gem ‘sqlite3’, ‘~> 1.3.6’, save the file, and run ‘bundle install’ again.