E: Package 'libreadline6' has no installation candidate


#1

I keep getting this error when using the first step of the installfest.

The line is:
sudo apt-get install autoconf automake bison build-essential curl git-core libapr1 libaprutil1 libc6-dev libltdl-dev libreadline6 libreadline6-dev libsqlite3-0 libsqlite3-dev libssl-dev libtool libxml2-dev libxslt-dev libxslt1-dev libyaml-dev ncurses-dev nodejs openssl sqlite3 zlib1g zlib1g-dev

I receive:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘git’ instead of ‘git-core’
Note, selecting ‘libreadline-dev’ instead of ‘libreadline6-dev’
Note, selecting ‘libxslt1-dev’ instead of ‘libxslt-dev’
Note, selecting ‘libncurses5-dev’ instead of ‘ncurses-dev’
Package libreadline6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libreadline6’ has no installation candidate


#2

A quick Google search didn’t yield much information. I think you can proceed without any issues.

What shows up if you type the following in your terminal?

dpkg --list|grep libreadline


#3

Also having this issue - when I input the above I get in response

ii libreadline7:amd64 7.0-3


#4

You are using Debian? Which version?


#5

Even i have the same issue.


#6

I can confirm you can proceed without issue. RVM will install it if you need it.