Download problem(firefox ubuntu idk)


#1

I instaled VM xubuntu and all of that but when i try to download VS code firefox it wont download it keeps falling
so anybody knows how to fix this ?


#2

How are you trying to download and install it? Are you downloading the .deb file from here?

If so, what do you mean it keeps failing? What error does it give you? Another option to consider is using Snap. If you are running Xubunutu 16.04 or newer it looks like snap is already installed, so from the Terminal you could just run…
sudo snap install code --classic
…and that should install VS Code for you. If you are running an older version of Xubuntu, or don’t have Snap, you can first run this to install it…
sudo apt update && sudo apt install snapd
…then re-run the above command again in the Terminal.

If these things don’t work let us know and we’ll go from there.


#3

I managed to download it somehow it was slow
In firefox download it would just say failed and i pressed on retry until it downloaded, piece by piece and that was just for the VS code(haven’t download anything else) hopefully i won’t have any more problems with that
i have the 18.04.1 version


#4

And now it wont download ruby rbenv install 2.6.5 --verbose
This is what i get rbenv install 2.6.5 --verbose
/tmp/ruby-build.20191203155455.11677.DQgJrM ~
Downloading ruby-2.6.5.tar.bz2…
-> https://cache.ruby-lang.org/pub/ruby/2.6/ruby-2.6.5.tar.bz2
i tried multiple times but nothing
but the file will download on windows but not on the VM


#5

Hmm, I’m not entirely sure - it sounds like maybe the network settings for the virtual machine are giving you issues. Let’s start with getting some basic info, and we’ll dig deeper until we make some progress.

  1. What VM software are you using Xubuntu in? (VirtualBox, VMWare, etc.)
    a. If VirtualBox, did you install the “Extension Pack”? If not, download and install (you do this on Windows, not Xubuntu)
  2. For the Xubuntu VM, what are the network settings? (NAT, Bridged, Internal, etc)
  3. What is the IP Address of your VM, and is it set to DHCP or Static?
  4. Xubuntu 32 bit or 64 bit?
  5. Have you made any significant changes to the Xubuntu since you installed it?

I see you are on Windows, I’m on macOS but I’ll try this anyway - I’m going to set up a fresh copy of Xubuntu 18.04.1 in VirtualBox (with Extension Pack installed) and see how it behaves.


#6

I was wrong sorry about that coz now my pc also has the same problem


#7

Ah, well, it sounds like you need to figure out what is causing the connection issues in Windows, then. Do you have good/reliable internet? If you’re confident that is not the issue, then there could be quite a few factors to consider when addressing connectivity issues. I’d start with a general workflow of something like this:

  1. Wired or Wireless connection to your home router?
    a. Do other devices in your home connect this way? Do they also have issues?
    b. If yes, maybe an issue with the router
  2. If that doesn’t seem o be the issues, does your computer have a DHCP or Static address? What about DNS? Try setting a different DNS (something like 8.8.8.8, 1.1.1.1) for testing.
  3. Still no good? Do you have anti-virus software or a firewall? Is is blocking the download?
  4. Maybe you have a virus or malware of some kind causing issues… Do a scan and see if your computer has issues.

Starting with these things will help narrow down the root of the issue.


#8

I installed it on my laptop it works perfectly
so that isnt the problem
i have DHCP
I tried to change my DNS but nothing happend
I think i disabled everything
I tried to scan before nothing came out of it

Thank you for helping


#9

Alright, so it it’s something with that PC specifically, either an issue with Windows of the hardware. Something you could try is creating a brand new user on the system, reboot the computer and do a little testing under that new account. If the problems go away you can be comfortable that the issue is software. If you still have problems, then it might be a hardware problem, which you could confirm by booting a Linux Live CD and testing with that.

I hope this is helpful, I’m sorry I don’t have a more concrete answer for you at this point.


#10

It works now , i dont know why